Dolibarr pour Ubuntu ou Debian

De Dolibarr Open Source ERP CRM Wiki.

Logo ubuntu.png

Contents

Introduction

Dolibarr pour Ubuntu et Debian (DoliDeb) est une version de Dolibarr ERP/CRM packagée avec Mysql, PHP et Apache ou Lighttpd pour les plateformes Ubuntu ou Debian.

En quelques secondes, en installant le package, vous êtes capable de travailler sur Dolibarr, même si vous n'avez pas déjà de serveur Web ou si vous ne savez pas ce que sont Apache/Lighttpd, MariaDB/MySQL ou PHP. Une entrée nommée "Dolibarr ERP & CRM" est ajoutée dans le menu des applications de votre ordinateur.

Dolibarr pour Debian/Ubuntu est un package tout en un qui peut être téléchargé depuis le site https://www.dolibarr.fr/telechargements/ dans la categorie des versions stables (voir aussi sur le site internationnal https://www.dolibarr.org/downloads/).

Prérequis

Le package dolideb de dolibarr 3.4+ est compatible avec:

  • Debian Wheezy 7+
  • Ubuntu 13.04+

Installation/Mise à jour

Depuis le fichier .deb téléchargé

Pour installer un package récupéré par téléchargement manuel depuis l'espace téléchargement du site dolibarr.org, cliquer sur le fichier dolibarr.x.y.z.deb si vous êtes dans une fenêtre Nautilus, ou, taper depuis une console:

$ sudo apt-get update
$ sudo dpkg -i dolibarr_x.y.z-w.w_all.deb

x.y.z est la version de dolibarr, ex. dolibarr_3.1.0-1.1_all.deb

Dans le cas d'une erreur de dépendances, tapez:

$ sudo apt-get install -f

Cette commande corrigera l'ensemble des dépendances orphelines de votre système et finalisera l'installation du package dolibarr.

Note: Si après la configuration vous rencontrez des problèmes à l'utilisation du module WYSIWYG, allez dans le fichier /etc/dolibar/conf.php et commentez la ligne

$dolibarr_js_CKEDITOR=...

Depuis le dépôt PPA (version de développement)

Remarque importante : Cette manipulation est reservée au personnes qui souhaitent faire du développement ou tester une nouvelle version de Dolibarr en cours de développement. Toutes les versions non-stables (alpha, beta et RC) ne sont pas recommandées pour un usage en production. Pour télécharger une version stable de Dolibarr, voir le chapitre suivant.

Pour installer la version de développement depuis le dépôt PPA:

sudo add-apt-repository ppa:eldy/dolibarr-dev
sudo apt-get update && sudo apt-get install dolibarr

Note: Si après la configuration vous rencontrez des problèmes à l'utilisation du module WYSIWYG, allez dans le fichier /etc/dolibar/conf.php et commentez la ligne

$dolibarr_js_CKEDITOR=...

Autres informations

Les informations suivantes sont à destination des mainteneurs pour maintenir Dolibarr dans le dépôt Debian:

Outils personnels
  • Ask to contact@dolibarr.org to request an account to contribute to this documentation
  • Connexion
Autres langues
AnglaisEspagnolAllemand
Pas de traduction en Allemand.
Italien
Pas de traduction en Italien.
Grèque
Pas de traduction en Grèque.
<multilanguagemanager_cn>
Pas de traduction en &lt;multilanguagemanager_cn&gt;.

Social networks
Follow us on Google+ Follow us on Facebook Follow us on LinkedIn Follow us on Twitter