Dolibarr for Ubuntu or Debian

From Dolibarr Open Source ERP CRM Wiki

Logo ubuntu.png

Contents

Introduction

Dolibarr for Ubuntu or Debian (DoliDeb) is a version of Dolibarr ERP/CRM, packaged with Mysql, PHP and Apache or Lighttpd, with an automatic installer for Ubuntu or Debian users that don't have any technical knowledge.

In a few seconds, after installing this package, you are able to work on Dolibarr, even if you don't have already a web server or if you don't know what is Apache/Lighttpd, Mysql or PHP. Everything is installed for you.

Dolibarr for Ubuntu and Debian is an "all in one" package that can be downloaded from page https://www.dolibarr.org/downloads/. You will find it into the category "stable versions".

Pre-requisite

Package dolideb for dolibarr 3.4+ is compatible with :

  • Debian Wheezy 7+
  • Ubuntu 13.04+

Installation

From downloaded .deb package

To install the download .deb package found into the download area of dolibarr.org portal, first install the Dolibarr package.

  • For this, just click on the dolibarr.x.y.z.deb file if you use the file manager nautilus.

If you use a terminal console, type:

$ sudo dpkg -i dolibarr_x.y.z-w.w_all.deb

where x.y.z is the dolibarr version, ex. dolibarr_3.1.0-1.1_all.deb

If an error of dependency occurs, type

$ sudo apt-get install -f

This will fix all your system orphan dependencies.


Note: If after setup, you experience troubles using WYSIWYG module, go into file /etc/dolibar/conf.php and comment line

$dolibarr_js_CKEDITOR=...

From PPA repository (development version)

Remark: This method is to install a development version. If you are an end user without technical knowledge of Dolibarr, do not use this process but prefer next method. This process is dedicated to developer or advanced user that want to help us to debug the application.

To install Dolibarr from the PPA respository:

  • First define the PPA where Dolibarr packages are hosted
sudo add-apt-repository ppa:eldy/dolibarr-dev

If you get the following message after the first line :

sudo: add-apt-repository: command not found

Run this and try again :

sudo apt-get install python-software-properties
  • Then, refresh your database of hosted packages an launch install od Dolibarr package
sudo apt-get update && sudo apt-get install dolibarr


Note: If you experience troubles using WYSIWYG module, go into file /etc/dolibarr/conf.php and comment line

$dolibarr_js_CKEDITOR=...

Other information

Following information are usefull for Dolibarr team to maintain package into Debian: TCPDF: Access GIT developper: git+ssh://git.debian.org/git/collab-maint/tcpdf.git TCPDF: Access GIT anonymous read only: git://anonscm.debian.org/collab-maint/tcpdf.git (http://anonscm.debian.org/git/collab-maint/tcpdf.git)

Personal tools
  • Ask to contact@dolibarr.org to request an account to contribute to this documentation
  • Log in
In other languages
FrenchSpanishDeutsch
No translation in Deutsch.
Italian
No translation in Italian.
Greek
No translation in Greek.
<multilanguagemanager_cn>
No translation in &lt;multilanguagemanager_cn&gt;.

Social networks
Follow us on Google+ Follow us on Facebook Follow us on LinkedIn Follow us on Twitter