Installation manuelle sous Windows

From Dolibarr ERP CRM Wiki
Jump to navigation Jump to search


Cette page décrit l'installation des différents composants nécessaires au bon fonctionnement de Dolibarr sur un environnement Windows

L'installation a été réalisée sous Windows 10 mais devrait être fonctionnelle pour les versions antérieures de Windows - certaines captures d'écrans ne correspondront juste pas.

Si vous êtes débutant, sachez que la section Installation - Mise à jour Avec DoliWamp (package Windows .exe) aborde également l'installation automatisée avec DoliWamp.


L'intérêt d'installer soit même les différents composants "Serveur" nécessaires au bon fonctionnement de Dolibarr est la possibilité de choisir des versions plus récentes que celles proposées en standard par l'installeur DoliWamp.

C'est aussi un excellent moyen de comprendre comment cela fonctionne et d'approfondir ses connaissances au niveau du déploiement et de la maintenance d'une instance Dolibarr.


Cette page de documentation a été rédigée dans l'objectif d'être compréhensible au plus grand nombre (quelque-soit le niveau informatique). Certaines précisions pourront apparaître comme triviales pour certain·e·s mais seront sans nul doute utiles pour d'autres. Si vous êtes (grand·e) débutant·e, n'essayez pas d'aller vite et prenez bien le temps de lire attentivement les différentes sections de la page (prévoyez une grosse demie-journée pour la mise en œuvre).


Dans la page suivante, il a été essayé autant que possible d'expliquer les différentes actions que vous allez effectuer (le but étant bien de comprendre et non de copier/coller ou d'appliquer mécaniquement des instructions). Pour distinguer facilement les explications des actions à effectuer, sachez que l'ensemble des actions à effectuer sont précédées d'une puce (•).


Si vous avez des questions ou besoin de précisions, n'hésitez pas à les poser sur le fil dédié du forum francophone : Installation manuelle sur Windows (sur dolibarr.fr/forum)


Architecture de Dolibarr

Dolibarr est une application Web de type "Client/Serveur".

Elle nécessite donc un Serveur Web avec le langage de script PHP ainsi qu'un Système de Gestion de Base de Données Relationnelle pour fonctionner.

Architecture Client/Serveur de Dolibarr


Fonctionnement

Du côté "Client", vous utilisez un navigateur Internet (Firefox, Chrome, Opera, Internet Explorer, etc.) pour accéder à l'interface de Dolibarr en tapant l'adresse du Serveur Web.

Dès que vous tapez l'adresse à laquelle le Serveur Web répond (par exemple http://localhost/dolibarr), ce dernier va chercher à afficher la page principale du sous répertoire dolibarr (selon la configuration du Serveur Web, la page principale d'un répertoire - aussi appelée page d'index - peut être par exemple index.html, index.htm ou index.php).

En général, par défaut, le Serveur Web sera configuré pour reconnaître uniquement les fichiers index.html comme fichiers d'index mais nous verrons ensemble comment ajouter les fichiers index.php.

Les fichiers .php étant des fichiers de scripts rédigés dans le langage PHP, ils ne seront pas directement compréhensibles par le navigateur du "Client" qui n'est capable d'afficher que du HTML.

Nous devrons donc dire au Serveur Web que quand il rencontre un fichier avec l'extension .php, il devra utiliser son module mod_php pour interpréter (ou convertir si vous préférez) le code PHP en code HTML avant de le renvoyer au "Client" (c'est à dire le navigateur).

Enfin, nous avons également besoin d'installer un Système de Gestion de Base de Données Relationnelle, ici MariaDB pour stocker les données de Dolibarr (ce sont les scripts PHP de Dolibarr qui interagiront avec le SGBDR pour écrire ou lire des données depuis celui-ci).

Installation et configuration de MariaDB

Nous allons tout d'abord installer le serveur de bases de données MariaDB.


Télécharger MariaDB

  • Rendez vous sur le site de téléchargement de MariaDB et cliquez sur le bouton vert Download xx.x.xx Stable now! (normalement le second bouton vert de la page).
  • Dans la colonne de droite, permettant de filtrer les fichiers disponibles :
  • Cliquez sur le lien pour télécharger l'unique fichier désormais affiché dans la liste.


Installer MariaDB

A ce niveau, MariaDB est désormais installé et démarré. Comme un "Service" Windows a été créé, le SGBDR sera automatiquement démarré à chaque (re)démarrage de l'ordinateur.


Installation et configuration de PHP


Télécharger PHP

  • Rendez vous sur le site https://windows.php.net/download
  • Dans la liste des téléchargements proposés, prenez la dernière version Thread Safe de PHP 7.4.x correspondant à votre architecture (x64 si votre système est 64 bits ou x86 si votre système est 32 bits).
    • Il s'agit normalement du deuxième téléchargement proposé (Attention ! Prenez bien garde de télécharger la version Thread Safe et PAS Non Thread Safe).
  • Une fois que vous avez trouvé la bonne version, téléchargez le fichier en cliquant sur le lien Zip.


Extraire l'archive pour installer PHP

  • Une fois téléchargée, effectuez un clic droit sur l'archive et sélectionnez Extraire tout...
  • Indiquez C:\php comme chemin de destination et cliquez sur Extraire.


Extraire PHP.png


Configurer PHP

Maintenant que PHP est décompressé au bon endroit, nous allons configurer quelques réglages.

PHP est livré avec des extensions et Dolibarr a besoin que certaines de ces extensions soient activées (elles ne le sont pas par défaut).

Activer l'affichage des Extensions de noms de fichiers
  • Dans l'Explorateur de fichiers Windows, cliquez sur l'onglet Affichage et cochez la case Extensions de noms de fichiers du groupe Afficher/Masquer.
Activer l'affichage des Extensions de noms de fichiers.


Créer le fichier de configuration de PHP à partir du modèle

Pour personnaliser votre installation de PHP, il va falloir modifier le fichier de configuration de php (le fichier php.ini).

  • Rendez vous dans le dossier où vous avez décompressé PHP (C:\php) en utilisant l'Explorateur de fichiers Windows > Disque Local (C:) > php (si vous aviez coché la case Afficher les dossiers extraits une fois l'opération terminée lors de l'extraction de l'archive, l'Explorateur de fichiers Windows devrait déjà être ouvert au bon endroit).

Dans ce dossier contenant les fichiers de PHP, vous trouverez deux fichiers de configuration "modèle" php.ini-development et php.ini-production.

  • Effectuez une copie (clic droit, Copier) du fichier php.ini-production et collez le dans le même répertoire (clic droit, Coller).
  • Renommez le fichier copié (php - Copie.ini-production) en php.ini (clic droit, Renommer sur le fichier).

Lors de la validation du nouveau nom de fichier, Windows vous avertira suite à la modification de l'extension du fichier (vous devez répondre Oui à cette question pour valider le renommage du fichier).

Avertissement Windows lors du changement d'extension d'un fichier.



Activer les extensions PHP nécessaires à Dolibarr

Double-cliquez sur le fichier php.ini pour l'ouvrir dans Bloc-notes Windows et pouvoir ainsi le modifier.

Faites défiler le fichier pour trouver la section débutant par Dynamic Extensions encadré par des ; (environ à la moitié du fichier) :

;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;

Dans cette section, vous allez devoir enlever le ; devant certaines des extensions pour les charger (changer par exemple ;extension=gd2 en extension=gd2).

Enlevez le ; devant les lignes ;extension=curl, ;extension=gd2, ;extension=intl, ;extension=mysqli.

Modifier certains autres paramètres de PHP

Astuce : pour trouver facilement un paramètre dans le fichier php.ini, vous pouvez utiliser la fonction Rechercher du Bloc-notes Windows (menu Edition > Rechercher ou Ctrl + F). Saisissez votre recherche puis cliquez sur Suivant. Selon votre position dans le fichier, n'hésitez pas à inverser le sens de la recherche en sélectionnant l'option Haut au lieu de Bas dans le cadre Direction puis à cliquer de nouveau sur suivant pour effectuer la recherche dans le sens inverse du fichier.

La boîte de dialogue Rechercher permettant de rechercher un texte dans le fichier.


Régler le fuseau horaire

En dessous de la section :

;;;;;;;;;;;;;;;;;;;
; Module Settings ;
;;;;;;;;;;;;;;;;;;;

Sous la sous-section [Date], remplacez la ligne ;date.timezone = par date.timezone = Europe/Paris (n'oubliez pas de retirer le ; en début de ligne).

Augmenter la taille des fichiers pouvant être téléversés

Par défaut, les fichiers pouvant être téléversés sur le serveur par l'intermédiaire du bouton Parcourir... des formulaires de Dolibarr (relevés bancaires PDF, factures fournisseurs, etc.) sont limités à une taille de 2M.

Si vous le souhaitez, vous pouvez augmenter cette limite en modifiant ces lignes :

  • remplacez la ligne upload_max_filesize = 2M par upload_max_filesize = 16M par exemple ;
  • si vous choisissez une valeur supérieure à 8M pour upload_max_filesize, vous aurez également besoin de remplacer post_max_size = 8M par post_max_size = 16M.


Enregistrez le fichier (Fichier > Enregistrer ou Ctrl + S) et fermez-le.

Nous avons maintenant configuré PHP.

Installation et configuration de Apache2

Télécharger Apache2

  • Rendez-vous sur le site https://www.apachelounge.com/download/
  • Téléchargez le fichier correspondant à l'architecture de votre système d'exploitation en cliquant sur le lien (Win64 pour 64 bits ou Win32 pour 32 bits).

Extraire l'archive pour installer Apache2

Contrairement à l'installation de PHP, nous allons procéder légèrement différemment pour la décompression de l'archive Apache2.

Au lieu d'extraire l'ensemble de l'archive, nous n'allons extraire que le dossier Apache24.

  • Pour ce faire, commencez par double-cliquer sur l'archive httpd-x.x.xx-winxx-VSxx.zip pour l'ouvrir dans l'Explorateur de fichiers Windows.
  • Ouvrez de nouveau l'Explorateur de fichiers Windows puis rendez vous dans le Disque Local (C:).
  • Faites glisser le dossier Apache24 depuis l'archive dans le Disque Local (C:).
Décompression de Apache2 en faisant glisser le dossier Apache24 dans le Disque Local (C:)

S'ensuit une copie de fichiers (plus longue cette fois que pour PHP) correspondant à la décompression de l'archive dans le Disque Local (C:).

Copie des fichiers depuis l'archive Apache2 vers le Disque Local (C:)

Configurer Apache2

Maintenant que Apache2 est décompressé, nous allons avoir besoin de modifier quelques paramètres de son fichier de configuration.

  • Avec l'Explorateur de fichiers Windows, rendez-vous dans le Disque Local (C:) puis dans le répertoire Apache24. Enfin, accédez au répertoire conf.
  • Double-cliquez sur le fichier httpd.conf pour ouvrir le fichier avec le Bloc-notes Windows et modifier ainsi le fichier de configuration de Apache2.
Renseigner le nom d'hôte du Serveur Web
  • Cherchez la ligne #ServerName www.example.com:80 et remplacez la par ServerName localhost:80.
Traiter les fichiers index.php comme des fichiers d'index
  • Cherchez le bloc
<IfModule dir_module>
    DirectoryIndex index.html
</IfModule>

et remplacez le par

<IfModule dir_module>
    DirectoryIndex index.php index.html
</IfModule>

De cette façon, lorsque nous accéderons à un répertoire, Apache2 cherchera d'abord s'il existe un fichier index.php avant de regarder s'il existe un fichier index.html.

Interpréter les fichiers *.php

Vous vous souvenez, au début, dans la section introductive sur l'architecture de Dolibarr, je vous ai indiqué que les navigateurs (Firefox, Chrome, Internet Explorer, etc.) que nous utilisons ne peuvent comprendre et afficher que des pages Web rédigées en langage HTML. Nous devons donc dire à Apache2 d'interpréter (convertir) les fichiers *.php en code HTML compréhensible par les navigateurs.

  • Tout à la fin du fichier httpd.conf, sautez une ligne puis collez le bloc de code suivant pour indiquer à Apache2 d'interpréter les fichiers *.php :
LoadModule php7_module "c:/php/php7apache2_4.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/php"

Ceci indiquera à Apache2 d'utiliser le php7_module fourni avec PHP que nous avons installé précédemment pour interpréter les fichiers *.php

  • Enregistrez le fichier httpd.conf (Fichier > Enregistrer ou Ctrl + S) et fermez-le.

Copier les fichiers nécessaires aux extensions PHP intl et curl dans le répertoire bin/ de Apache2

L'extension intl de PHP est responsable des fonctions d'internationalisation (de gestion des traductions) des applications qui l'utilisent. L'extension curl de PHP permet d'effectuer des requêtes vers (de contacter) des serveurs externes.

Dolibarr nécessite les extensions intl et curl et ces extensions ont besoin de certaines librairies (fichiers de fonctions) pour fonctionner.

Ces librairies sont fournies avec PHP, mais comme nous utilisons le php7_module avec Apache2, nous avons besoin de copier ces fichiers depuis le répertoire de PHP vers le répertoire bin/ de Apache2 pour que les extensions intl et curl puissent fonctionner correctement.

  • Avec l'Explorateur de fichiers Windows, rendez-vous dans le Disque Local (C:) puis dans le répertoire php (C:\php).
  • Sélectionnez les fichiers icudt65.dll, icuin65.dll, icuio65.dll, icuuc65.dll, libcrypto-1_1-x64.dll, libssl-1_1-x64.dll et libssh2.dll en cliquant sur le premier fichier, puis tout en maintenant la touche Ctrl de votre clavier, sélectionner les autres fichiers en cliquant dessus.
  • Copiez les fichiers (clic droit, puis Copier ou Ctrl + C).
  • Avec l'Explorateur de fichiers Windows, rendez-vous dans le Disque Local (C:) puis dans le répertoire Apache24 et ensuite dans le sous répertoire bin (C:\Apache24\bin).
  • Collez les fichiers (clic droit, puis Copier ou Ctrl + V).

Créer et démarrer le "Service" Windows pour lancer automatiquement Apache2

Dans la première partie de cette documentation, lorsque nous avons installé le SGBDR MariaDB, souvenez-vous, il y avait une page de l'assistant d'installation qui proposait de créer un "Service" Windows et de personnaliser son nom.

Les "Services" sont très pratiques et permettent de démarrer automatiquement une application au (re)démarrage de l'ordinateur. Contrairement au dossier de démarrage, les "Services" sont exécutés avant même l'ouverture d'une "Session" utilisateur Windows.

Nous allons donc créer un "Service" Windows pour démarrer automatiquement Apache2 au (re)démarrage de l'ordinateur.

  • À côté du bouton Windows permettant d'ouvrir le menu démarrer, dans la zone de recherche "Taper ici pour rechercher", cliquez puis saisissez cmd. Dans la liste des options proposées, choisissez "Exécuter en tant qu'administrateur" puis validez la fenêtre de Contrôle de compte utilisateur.
Exécuter l'Invite de commandes Windows en tant qu'administrateur
  • Saisissez la commande suivante dans l'Invite de commandes Windows puis validez avec la touche Entrée :
C:/Apache24/bin/httpd.exe -k install
Création du "Service" Windows avec l'Invite de commandes Windows exécutée en tant qu'administrateur.

Le "Service" que nous venons de créer n'est pour l'instant pas démarré donc, nous avons besoin de le démarrer pour la première fois (il sera ensuite démarré automatiquement à chaque (re)démarrage de l'ordinateur).

  • Saisissez la commande suivante dans l'Invite de commandes Windows puis validez avec la touche Entrée :
net start Apache2.4
Démarrage du "Service" Windows Apache2.4 avec l'Invite de commandes Windows exécutée en tant qu'administrateur.

Si le service ne démarre pas correctement, c'est parce que votre fichier de configuration httpd.conf est invalide.

Pour déterminer la cause de votre erreur le cas échéant, vous pouvez saisir la commande suivante dans l'Invite de commandes Windows :

C:\Apache24\bin\httpd.exe -n "Apache2.4" -t

Cette commande permet de tester la validité de votre fichier httpd.conf et devrait vous renvoyer la ligne à laquelle l'erreur est rencontrée.

Outre les erreurs de syntaxe courantes en cas d’inattention, l'une des erreurs les plus fréquente est l'absence du fichier C:\php\php7apache2_4.dll. Ce fichier est en effet absent si vous avez téléchargé la mauvaise version de PHP (Non Thread Safe) au lieu de la version Thread Safe. Dans ce cas, téléchargez la bonne archive (Thread Safe) et effectuez de nouveau la partie Installation_manuelle_sous_Windows#Extraire_l'archive_pour_installer_PHP.

Une autre problématique pouvant être rencontrée est l'impossibilité de démarrer Apache2 car le port 80 est déjà utilisé par un autre programme. Voyez dans ce cas l'annexe Que sont les "Ports d'écoute" et comment savoir si un programme occupe déjà un port spécifique ? pour savoir comment procéder.

Une fois vos éventuelles erreurs corrigées, essayez de nouveau de démarrer le Service Apache2.4 avec la commande mentionnée précédemment.


Vous pouvez maintenant fermer l'Invite de commandes Windows.

Apache2.4 est désormais installé en tant que "Service" Windows et démarré. Le "Serveur Web" Apache2 sera donc démarré automatiquement à chaque (re)démarrage de l'ordinateur.

Vérifions que tout fonctionne

Avant de passer à la suite (l'installation proprement dite de Dolibarr), prenons un instant pour vérifier que notre installation actuelle fonctionne correctement.

Vérifier le bon fonctionnement du SGBDR MariaDB

  • À côté du bouton Windows permettant d'ouvrir le menu démarrer, dans la zone de recherche "Taper ici pour rechercher", cliquez puis saisissez mysql client. Dans la liste des options proposées à droite, choisissez "Ouvrir" ou cliquez sur le titre complet de l'application pour la lancer (MySQL Client (MariaDB 10.4 (x64)).
Exécuter l'application MySQL Client (MariaDB 10.4 (x64))

L'application MySQL Client (MariaDB 10.4 (x64) se lance.

Il s'agit d'une invite de commandes spécifique à votre SGBDR MariaDB permettant d'exécuter des commandes de bases de données (en langage SQL).

  • Saisissez le mot de passe de l'administrateur des bases de données que vous avez choisi lors de l'installation de MariaDB précédemment (au quatrième écran de l'installeur) puis appuyez sur Entrée pour valider le mot de passe.
  • Saisissez l'instruction SQL SHOW DATABASES; pour lister les bases de données actuelles puis appuyez sur Entrée pour valider la commande.

MariaDB devrait vous répondre avec la liste des bases de données automatiquement créées lors de l'installation : information_schema, mysql, performance_schema et test.

Liste des bases de données gérées par le SGBR MariaDB installé sur notre ordinateur.


Ceci conclu notre test de bon fonctionnement de MariaDB.

Nous avons en effet été en mesure de nous connecter avec succès au SGBDR avec le mot de passe administrateur que nous avions précédemment choisi et l'exécution d'une instruction SQL ( SHOW DATABASES; ) a correctement fonctionné.

Vous pouvez désormais fermer l'application MySQL Client (MariaDB 10.4 (x64).

Vérifier le bon fonctionnement de Apache2

  • Démarrez votre Navigateur Web favori (Firefox, Google Chrome, Opera, Brave, Vivaldi, Internet Explorer, Edge, etc.) et saisissez l'adresse http://localhost dans la barre d'adresse puis validez par Entrée.

Si vous avez correctement installé Apache2, le "Serveur Web" devrait vous répondre un joli It works! que l'on peut traduire par "Ça fonctionne !" en français.

La page par défaut du Serveur Web Apache2.


Ceci conclu notre test de bon fonctionnement de Apache2.

Nous avons en effet été en mesure d'obtenir une réponse du Serveur Web Apache2 (en l'occurence It works!) ce qui prouve qu'il a été correctement installé et démarré.

Vous pouvez désormais fermer votre Navigateur Web.

Vérifier le bon fonctionnement de PHP

Concernant la partie PHP, nous avons deux choses à vérifier.

  1. Les fichiers index.php sont correctement reconnus lorsque l'on accède à un répertoire.
  2. Les fichiers *.php sont correctement interprétés par PHP et renvoient bien du HTML.
  • Avec l'Explorateur de fichiers Windows, rendez-vous dans le Disque Local (C:) puis dans le répertoire Apache24. Enfin, accédez au répertoire htdocs (C:\Apache24\htdocs).

Vous trouverez dans ce dossier un fichier index.html. C'est le fameux fichier qui contient <html><body><h1>It works!</h1></body></html> soit la réponse en HTML que nous a renvoyé Apache2 quand nous avons accédé au serveur en tapant l'adresse http://localhost.

  • Dans le dossier htdocs (C:\Apache24\htdocs), créez un nouveau dossier test (clic droit, Nouveau > Dossier).
  • Double-cliquez sur le nouveau dossier test pour entrer dedans.
  • Créez un nouveau fichier index.php (clic droit, Nouveau > Document texte).
  • Ouvrez le document avec le Bloc-notes Windows (clic droit, Ouvrir avec > Bloc-notes ; si Bloc-notes n'est pas proposé, cliquez sur Choisir une autre application, puis sur Plus d'applications et sélectionnez Bloc-notes dans la liste avant de valider par OK).
  • Saisissez le code PHP suivant dans le fichier :
<?php
phpinfo();
  • Enregistrez le fichier index.php (Fichier > Enregistrer ou Ctrl + S) et fermez-le.

Lorsque PHP traite un fichier, il cherche les balises d'ouverture et de fermeture (<?php et ?>) qui délimitent le code qu'il doit interpréter. <?php permet donc d'indiquer que nous allons écrire du code PHP.

La fonction phpinfo affiche de nombreuses informations sur la configuration de PHP, ce qui nous permettra de vérifier que PHP fonctionne et que nous avons bien activé les bonnes extensions.

  • Démarrez votre Navigateur Web favori (Firefox, Google Chrome, Opera, Brave, Vivaldi, Internet Explorer, Edge, etc.) et saisissez cette fois l'adresse http://localhost/test dans la barre d'adresse puis validez par Entrée.

Apache2 devrait vous renvoyer une page générée par PHP contenant l'ensemble des informations de configuration. Si vous faites défiler cette page, vous devez voir des sections liées aux extensions que nous avons chargées précédemment (notamment curl, gd2, intl et mysqli) Si l'une de ces sections n'est pas affichée, cela signifie que l'extension n'est pas chargée (vous avez donc oublié de retirer un point virgule devant le nom d'une extension lors de votre édition du fichier C:\php\php.ini ou alors vous avez oublié de copier l'un des fichiers mentionnés dans la section Copier les fichiers nécessaires aux extensions PHP intl et curl dans le répertoire bin/ de Apache2. Vérifiez et corrigez le cas échéant vos oublis puis redémarrez le Service Apache2.4 pour que vos modifications soient prises en compte (voir l'annexe Comment gérer les "Services" Windows ? pour savoir comment redémarrer un Service existant).

Apache2 nous renvoie la page contenant les informations de configuration générée par PHP.


Ceci conclu notre test de bon fonctionnement de PHP.

Nous avons en effet été en mesure de vérifier que PHP fonctionne correctement car il renvoie bien les informations liées à sa configuration courante.

De plus, les fichiers PHP index.php sont bien interprétés comme des fichiers d'index car notre fichier a bien été exécuté en saisissant http://localhost/test (nous n'avons pas eu besoin de saisir http://localhost/test/index.php ).

  • Avec l'Explorateur de fichiers Windows, rendez-vous dans le Disque Local (C:) puis dans le répertoire Apache24. Enfin, accédez au répertoire htdocs (C:\Apache24\htdocs).
  • Supprimez le dossier test que nous avions précédemment créé.

Vous pouvez désormais fermer l'Explorateur de fichiers Windows ainsi que votre Navigateur Web.


Installation de Dolibarr

C'est la fête (sortez les ballons et les cotillons), le moment que vous attendiez tant est enfin arrivé ! Nous allons enfin pouvoir installer Dolibarr.

Télécharger Dolibarr

  • Rendez-vous sur les miroirs SourceForge à l'adresse https://sourceforge.net/projects/dolibarr/files/
  • Cliquez sur le dossier Dolibarr ERP-CRM, puis sur le dernier numéro de version et cliquez sur le fichier portant l'extension .zip pour le télécharger.

Créer le dossier documents de Dolibarr

Dolibarr a besoin d'un dossier documents dans lesquels il stocke les documents générés (Propositions commerciales, Commandes, Factures, Fiches d'interventions, Bons de livraison) mais aussi les documents téléversés par l'utilisateur (Relevés de compte, Factures fournisseurs, etc.).

Par mesure de sécurité, il est préférable de créer le dossier documents en dehors du Serveur Web (pour nous Apache2).

  • Avec l'Explorateur de fichiers Windows, rendez-vous dans le Disque Local (C:).
  • Créez un nouveau dossier dolibarr puis double-cliquez dessus et créez de nouveau un dossier documents. Nous obtenons donc le répertoire C:\dolibarr\documents

Extraire l'archive de Dolibarr

Pour l'extraction de l'archive Dolibarr, nous allons procéder de manière similaire à celle de Apache2 en utilisant la technique du glisser-déposer.

  • Avec l'Explorateur de fichiers Windows, rendez-vous dans le Disque Local (C:) puis dans le répertoire Apache24. Enfin, accédez au répertoire htdocs (C:\Apache24\htdocs).
  • Créez le dossier dolibarr puis double-cliquez dessus.
  • Double-cliquez ensuite sur l'archive de Dolibarr que vous venez de télécharger pour l'ouvrir dans une nouvelle fenêtre de l'Explorateur de fichiers Windows.
  • Naviguez dans l'archive vers le dossier dolibarr-xx-x-x puis vers le dossier htdocs.
  • Sélectionnez l'ensemble des fichiers du répertoire htdocs en utilisant le bouton Sélectionner tout du groupe Sélectionner de l'onglet Accueil de l'Explorateur de fichiers Windows (ou en utilisant le raccourci clavier Ctrl + A).
  • Faites glisser les fichiers sélectionnés vers le dossier dolibarr créé précédemment (dans l'autre fenêtre).
Extraction du répertoire htdocs de l'archive Dolibarr dans le répertoire dolibarr du Serveur Web Apache2.

En raison du grand nombre de fichiers fournis avec Dolibarr et en fonction de la vitesse de votre disque dur ou SSD, la décompression peut prendre plusieurs minutes.

Décompression de l'archive Dolibarr vers le répertoire dolibarr du Serveur Web Apache2.


Installer Dolibarr

  • Démarrez votre Navigateur Web favori (Firefox, Google Chrome, Opera, Brave, Vivaldi, Internet Explorer, Edge, etc.) et saisissez l'adresse http://localhost/dolibarr dans la barre d'adresse puis validez par Entrée pour débuter l'installation de Dolibarr.
Configurer la base de données

Pour que les explications soient plus simples, j'ai numéroté les différents champs que vous avez besoin de modifier.

0 - Cochez la case Créer la base de données.

1 - Renseignez dolibarr comme identifiant (cet utilisateur sera créé dans MariaDB par l'installeur Dolibarr et aura uniquement l'autorisation d'accéder à la base dolibarr nouvellement créée).

2 - Renseignez un mot de passe différent (que vous n'avez jamais utilisé, et qui sera spécifique à l'utilisateur MariaDB dolibarr)

3 - Cochez Créer le propriétaire ou lui affecter les droits à la base (ceci demande à l'installeur Dolibarr de créer le nouvel utilisateur MariaDB intitulé dolibarr que nous avons renseigné si dessus avec le mot de passe spécifié).

4 - Saisissez root (il s'agit de l'identifiant utilisateur MariaDB de l'administrateur des bases de données ayant tous les droits).

5 - Saisissez le mot de passe MariaDB de l'administrateur des bases de données que vous avez choisi lors de l'installation de MariaDB (écran 4 de l'installation).


Terminer la configuration de Dolibarr

Maintenant que Dolibarr est installé avec succès, nous devons finir le paramétrage initial (il s'agit de renseigner les informations de votre société et d'activer un ou plusieurs modules à utiliser).

  • Renseignez votre nom d'utilisateur et votre mot de passe et cliquez sur Se connecter.

Vous êtes automatiquement redirigé vers la page Configuration de Dolibarr car le paramétrage initial n'est pas terminé.

  • Dans le menu de gauche, sous Configuration, cliquez sur Société/Organisation et renseignez les informations sur votre société puis cliquez sur Enregistrer en bas de page.
  • Toujours dans le menu de gauche, cliquez ensuite sur Modules/Applications puis activez les modules souhaités en cliquant sur l'icône représentant un interrupteur en bout de ligne.

Nous avons maintenant terminé la configuration initiale de Dolibarr. Bravo !

  • Cliquez sur Mon tableau de bord pour afficher la page de démarrage de Dolibarr.
La page Mon tableau de bord de Dolibarr. Elle présente actuellement des avertissements car nous n'avons pas créé de fichier install.lock et que le fichier de configuration de Dolibarr (conf.php) est accessible en écriture par le Serveur Web.
Créer le fichier install.lock

Le fichier install.lock est important, puisque il permet d'éviter que n'importe qui puisse relancer l'installation de Dolibarr en accédant à l'adresse http://localhost/dolibarr/install.

Si vous utilisez uniquement Dolibarr sur votre ordinateur et que celui-ci n'est pas accessible depuis le réseau (local ou Internet), il n'est pas forcément nécessaire de créer le fichier mais c'est une bonne habitude à prendre car vous serez peut-être amené par la suite à "ouvrir" votre installation Dolibarr.

  • Avec l'Explorateur de fichiers Windows, rendez-vous dans le Disque Local (C:) puis dans le répertoire dolibarr. Enfin, accédez au répertoire documents (C:\dolibarr\documents).
  • Créez un fichier install.lock (clic droit puis Nouveau > Document texte).
  • Dans votre Navigateur Internet, cliquez de nouveau sur le lien Mon tableau de bord de la colonne de gauche de Dolibarr et constatez que le premier avertissement relatif à l'absence de fichier install.lock a disparu.
Restreindre l'accès en écriture du Serveur Web au fichier conf.php
  • Avec l'Explorateur de fichiers Windows, rendez-vous dans le Disque Local (C:) puis dans le répertoire Apache24. Accédez au répertoire htdocs puis à dolibarr et enfin à conf (C:\Apache24\htdocs\dolibarr\conf).
  • Effectuez un clic droit sur le fichier conf.php et sélectionnez l'option Propriétés
  • Dans la boîte de dialogue Propriétés de : conf.php, cochez la case Lecture seule pour l'option Attributs puis cliquez sur OK.
  • Dans votre Navigateur Internet, cliquez de nouveau sur le lien Mon tableau de bord de la colonne de gauche de Dolibarr et constatez que le second avertissement relatif à l'accessibilité en écriture au Serveur Web du fichier conf.php a disparu.
Activation de l'attribut Lecture seule pour le fichier de configuration principal conf.phpde Dolibarr.


Annexes

Que sont les "Ports d'écoute" et comment savoir si un programme occupe déjà un port spécifique ?

Qu'est-ce qu'un "Port d'écoute"

Lorsque vous installez un programme "Serveur", vous devez choisir un port sur lequel le programme sera disponible et qui sera utilisé par le programme "Client" pour communiquer avec le "Serveur". Le port est donc le canal de communication entre le "Client" et le "Serveur" (souvenez vous du schéma d'architecture en début de page).

Le port par défaut qu'utilise le Serveur de Bases de Données MariaDB est le port 3306.

Le port par défaut qu'utilise le Serveur Web Apache2 pour communiquer avec le "Client" (votre Navigateur Internet) est le port 80.

Si d'autres programmes utilisent déjà soit le port 3306 ou le port 80, vous aurez besoin de choisir un autre port sur lequel le Serveur de Bases de Données MariaDB ou le Serveur Web Apache2 sera disponible.

Comment savoir si un programme occupe déjà un port spécifique ?

Si vous essayez d'installer le Serveur de Bases de Données MariaDB ou le "Service" Windows du Serveur Web Apache2 sur un port qui est déjà occupé par un autre programme, vous rencontrerez une erreur.

Pour vérifier quel programme écoute sur quel port, vous pouvez utiliser le Moniteur de ressources Windows.

  • À côté du bouton Windows permettant d'ouvrir le menu démarrer, dans la zone de recherche "Taper ici pour rechercher", cliquez puis saisissez moniteur de ressources. Dans la liste des options proposées à droite, choisissez "Ouvrir" ou cliquez sur le titre complet de l'application pour la lancer (Moniteur de ressources).
Exécuter l'application Moniteur de ressources de Windows
  • Dans le Moniteur de Ressources, cliquez sur l'onglet Réseau.
  • Dans la section Ports d'écoute, triez la colonne Port afin de pouvoir rechercher plus facilement.
  • Cherchez dans la colonne Port le port qui vous intéresse (par exemple 80 pour le port standard du Serveur Web Apache2 ou 3306 pour le Serveur de Bases de Données MariaDB).
Un programme "écoute" déjà sur le port 80, il s'agit de httpd.exe (c'est à dire Apache2).

Si vous ne trouvez pas de ligne pour le numéro de port recherché, alors, c'est parfait (cela signifie qu'aucun programme n'écoute sur ce port et qu'il est donc disponible).

Si en revanche vous trouvez une correspondance, alors un programme écoute déjà sur ce port et vous devrez choisir un autre port d'écoute lors de l'installation de votre serveur.

Choisir un autre port que le port par défaut 3306 pour MariaDB

À la cinquième page de l'installeur MariaDB, renseignez un autre port dans la case TCP port: (par exemple le 3308 - mais assurez vous que le port que vous choisissez n'est pas déjà utilisé en utilisant la technique spécifié ci-dessus).

Suite à votre changement de port pour MariaDB, lors de votre installation de Dolibarr, au moment de renseigner le port dans la section Base de données Dolibarr, n'oubliez pas de renseigné le port de remplacement que vous avez choisi au lieu du port standard 3306.

Choisir un autre port que le port par défaut 80 pour Apache2

Lors de la personnalisation du fichier de configuration de Apache2, remplacez la ligne ServerName localhost:80 par ServerName localhost:<mon_port> pour spécifier un autre port (par exemple ServerName localhost:8080 pour utiliser le port 8080 - mais assurez vous que le port que vous choisissez n'est pas déjà utilisé en utilisant la technique spécifié ci-dessus). Vous aurez également besoin de remplacer le 80 de la ligne Listen 80 : par le numéro de port que vous aurez choisi.

Suite au changement de port d'écoute, vous devrez spécifier le port dans les adresses que vous taperez dans votre navigateur : par exemple http://localhost:8080, http://localhost:8080/test, http://localhost:8080/dolibarr, etc. au lieu de http://localhost, http://localhost/test, http://localhost/dolibarr.

Comment gérer les "Services" Windows ?

Nous avons vu dans cette documentation la création de "Services" Windows permettant de démarrer automatiquement le Système de Gestion de Bases de Données MariaDB et le Serveur Web Apache2 au (re)démarrage de l'ordinateur.

Windows est livré avec une application permettant de gérer graphiquement les "Services". Il est ainsi possible de consulter leur statut (démarré, arrêté) et d'agir dessus (démarrer, arrêter, redémarrer).

  • À côté du bouton Windows permettant d'ouvrir le menu démarrer, dans la zone de recherche "Taper ici pour rechercher", cliquez puis saisissez services. Dans la liste des options proposées à droite, choisissez "Ouvrir" ou cliquez sur le titre complet de l'application pour la lancer (Services).
Exécuter l'application Services de Windows
  • Dans la liste des Services qui s'affichent, rechercher le Service pour lequel vous souhaitez consulter le statut ou effectuer une action (démarrage, arrêt, redémarrage). Cherchez par exemple MariaDB ou Apache2.

Dans la colonne État, vous pouvez vérifier le statut actuel du Service (sur la capture d'écran ci-dessous, nous constatons que le service Apache2.4 est En cours d'exécution, c'est à dire qu'il est démarré).

  • Effectuez un clic droit sur le Service à gérer pour afficher le menu contextuel puis sélectionnez l'action à effectuer (Démarrer, Arrêter ou Redémarrer).
Redémarrer le Service Apache2.4


Comment savoir si mon ordinateur exécute la version 32 bits ou 64 bits de Windows ?

Windows 10 et Windows 8.1
  1. Sélectionnez le bouton Démarrer, puis Paramètres > Système > À propos de.
  2. Sur la droite, sous Spécifications de l’appareil, consultez Type de système.
Windows 7
  1. Sélectionnez le bouton Démarrer, cliquez avec le bouton droit sur Ordinateur, puis choisissez Propriétés.
  2. Sous Système, consultez le type de système.

Rappel des différents répertoires d'installation utilisés

Composant/Logiciel Chemin d'installation
MariaDB C:\Program Files\MariaDB 10.4
Apache 2.4 C:\Apache24
PHP C:\php
Dolibarr (programme) C:\Apache24\htdocs\dolibarr
Dolibarr (documents) C:\dolibarr\documents
Dolibarr (données) C:\Program Files\MariaDB 10.4\data\dolibarr

⚠️ Attention ! Les fichiers présents dans le répertoire C:\Program Files\MariaDB 10.4\data\dolibarr sont les fichiers physiques de la base de données. Sauvegarder ces fichiers ne vous permettra de les réutiliser qu'avec la même version de la base de données. Une façon plus robuste d'effectuer une sauvegarde de la base de données est de réaliser un export en utilisant par exemple l'utilitaire mysqldump.

Comment sauvegarder mon installation manuelle

Dans Dolibarr, trois choses sont importantes à sauvegarder :

  • la base de données (MariaDB), qui contient toutes vos saisies (lignes de propositions commerciales, factures, etc.)
  • le dossier documents qui contient les documents PDF générés par Dolibarr (propositions commerciales, factures, etc.) ainsi que ceux téléversés.
  • le fichier de configuration conf/config.php qui contient les paramètres de connexion à votre base de données et d'autres informations de configuration.
Sauvegarder la base de données

Il existe plusieurs façons de sauvegarder la base de données.

Directement depuis Dolibarr
Sauvegarde de la base de données depuis Dolibarr

Une fois connecté à Dolibarr,

  • Sélectionnez le menu Sauvegarde dans la rubrique Outils d'administration,
  • Dans Compression, sélectionnez - pour plus de simplicité - Aucun (Windows n'intègre en effet pas en standard d'utilitaire permettant de dé-compresser les fichiers Gzip mais vous pouvez l'activer si vous disposez par exemple de 7-Zip, PeaZip, WinZip ou WinRar).
  • Cliquez sur Générer Sauvegarde.


Télécharger la sauvegarde de base de données

Une fois que la sauvegarde a été générée, vous pouvez la télécharger en cliquant sur le lien du fichier dans la section de droite Fichiers de sauvegarde de base de données existant

Manuellement en utilisant l'outil graphique HeidiSQL

Lors de l'installation du Système de Gestion de Bases de Données MariaDB, l'outil graphique HeidiSQL a également été installé.

  • À côté du bouton Windows permettant d'ouvrir le menu démarrer, dans la zone de recherche "Taper ici pour rechercher", cliquez puis saisissez heidisql. Dans la liste des options proposées à droite, choisissez "Ouvrir" ou cliquez sur le titre complet de l'application pour la lancer (HeidiSQL).
Exécuter l'application HeidiSQL


Nous allons maintenant définir la connexion à notre Système de Gestion de Bases de Données MariaDB en utilisant les informations de connexion dont nous disposons.

Exporter la base de données avec HeidiSQL
  • Effectuez un clic droit sur la base de données dolibarr et sélectionnez Exporter la base de données en SQL...


Paramétrer l'export de la base de données dans HeidiSQL
  • Cochez la case Retirer/DROP dans la section Table(s) : puis, dans Nom de fichier : choisissez le chemin où vous souhaitez exporter la sauvegarde et le nom du fichier. Si vous avez suivi l'ensemble de la documentation d'installation, un bonne pratique est de placer l'export au même endroit que lorsque vous le réalisez avec l'interface de Dolibarr (méthode du paragraphe ci-dessus) : C:\dolibarr\documents\admin\backup\%db-%date.sql . %db sera remplacé automatiquement par le nom de la base (dolibarr) et %date par la date et l'heure de l'export.
  • Cliquez sur Exporter pour lancer l'export.
Manuellement en utilisant l'Invite de commandes Windows
  • À côté du bouton Windows permettant d'ouvrir le menu démarrer, dans la zone de recherche "Taper ici pour rechercher", cliquez puis saisissez mariadb. Dans la liste des options proposées à droite, choisissez "Ouvrir" ou cliquez sur le titre complet de l'application pour la lancer (Command Prompt (MariaDB 10.4 (x64))).
Exécuter l'application Command Prompt (MariaDB 10.4 (x64))


L'invite de commandes se lance ; placez vous dans le répertoire des sauvegardes de base de données de Dolibarr (dans notre dossier documents) :

cd C:\dolibarr\documents\admin\backup

Saisissez la commande suivante pour sauvegarder la base de données où dolibarr-2020-05-20-14-30.sql correspondra au nom du fichier exporté (vous pouvez bien entendu mettre ce que vous voulez) :

mysqldump -u root -p --opt dolibarr > dolibarr-2020-05-20-14-30.sql

Vous devrez saisir le mot de passe de l'administrateur des bases de données que vous avez choisi lors de l'installation de MariaDB (écran 4 de l'assistant d'installation).

Sauvegarder le dossier documents et le fichier de configuration config.php

ℹ️ La rédaction de cette section n'est pas encore achevée. Revenez ultérieurement.

Directement depuis Dolibarr

ℹ️ La rédaction de cette section n'est pas encore achevée. Revenez ultérieurement.

Manuellement en utilisant l'Explorateur de fichiers Windows

ℹ️ La rédaction de cette section n'est pas encore achevée. Revenez ultérieurement.

Restaurer une sauvegarde

ℹ️ La rédaction de cette section n'est pas encore achevée. Revenez ultérieurement.

Manuellement en utilisant l'outil graphique HeidiSQL

ℹ️ La rédaction de cette section n'est pas encore achevée. Revenez ultérieurement.

Manuellement en utilisant l'Invite de commandes Windows

ℹ️ La rédaction de cette section n'est pas encore achevée. Revenez ultérieurement.

Comment mettre à jour Dolibarr

⚠️ Attention ! Avant d'entreprendre une mise à jour, vous devriez TOUJOURS vous assurez que vous disposez d'une sauvegarde complète de Dolibarr au cas où vous effectueriez une mauvaise manipulation afin de pouvoir revenir à un état antérieur fonctionnel.

ℹ️ La rédaction de cette section n'est pas encore achevée. Revenez ultérieurement.