安装前提条件

From Dolibarr ERP CRM Wiki
Jump to navigation Jump to search

Dolibarr 构建于以下组件:

OS (操作系统)

几乎所有操作系统都支持。

  • 客户端: 所有操作系统,只要可以运行浏览器。
  • 服务器: 所有操作系统,只要支持PHP和SQL。

例如: GNU/Linux, BSD, Windows, MacOS, AIX, ...


Windows 7 用户注意:

当使用Windows 7时,必须安装 Visual C++ Redistributable for Visual Studio 2012 Update 4
Dolibarr安装过程中的错误消息将指示你的系统是否安装了这个升级包。

确定你选择了32位版本 (vcredist_x86.exe). 这里可以得到:

* https://www.microsoft.com/en-us/download/details.aspx?id=30679


数据库

  • MySQL 5.0.3+ (所有 MySQL 操作/参数都支持).
!! 不要使用 MySQL 版本 5.5.40 或 5.5.41, 这两个版本存在致命错误,会导致数据丢失。

如果使用选项 mode=STRICT 返回警告或错误,请向我们报告。

  • MariaDB 5.0.3+
  • PostgreSQL 8.1.4+
  • MS SQL (实验支持尚未生效)
  • 数据库容量不小于1Mb / 100 顾客/供应商注册数。


PHP

  • 最低版本: 5.5.0+ (requires functions like DateTimeZone.getOffset, php-intl)
  • 支持: PHP 7.x until PHP 7.2
  • 开启支持用户会话。 (此为PHP的默认值)
  • Works 无论 safe_mode 参数值
  • PHP 设置必须允许使用最大内存 128Mb ( PHP 参数 memory_limit).

磁盘空间

版本 7.0.3

  • Dolibarr 程序文件使用大约 150 MByte 空间。
  • 额外的模块或模板需要更多的磁盘空间。
  • Dolibarr 数据库文件使用大约 35 MByte 空间。
  • 数据库系统还需要一些磁盘空间和更多的临时文件空间。

但是,如果上传连接的文件或存储生成的PDF或ODT文档,则需要更多的磁盘空间。存储空间需求取决于所附文件的数量和大小。


CPU

甚至可以使用一个旧的英特尔奔腾处理器. 如果您有超过30个用户,建议使用1GHz的CPU或更快。