Herramientas de Desarrollo - Opcional: Difference between revisions
Jump to navigation
Jump to search
No edit summary |
mNo edit summary Tag: 2017 source edit |
||
| (7 intermediate revisions by 3 users not shown) | |||
| Line 1: | Line 1: | ||
<!-- BEGIN interlang links --> | |||
<!-- Do NOT edit this section | |||
Links below are automatically managed by PolyglotBot | |||
You can edit links on the English source page : Environment_and_development_tools_-_Optional --> | |||
[[en:Environment_and_development_tools_-_Optional]] | |||
[[fr:Outils_de_développement_-_Composants_optionnels]] | |||
<!-- END interlang links --> | |||
{{TemplateDocDesarrollo}} | {{TemplateDocDesarrollo}} | ||
== Si desea realizar scripts en Perl == | == Si desea realizar scripts en Perl == | ||
* Instalación del plugin Eclipse para Perl: EPIC | * Instalación del plugin Eclipse para Perl: EPIC | ||
Para ello, utilizar el método''' Find And Install''' y agregar la URL de actualización: http://e-p-i-c.sourceforge.net/updates | Para ello, utilizar el método''' Find And Install''' y agregar la URL de actualización: http://e-p-i-c.sourceforge.net/updates | ||
== Si trabaja bajo Windows == | == Si trabaja bajo Windows == | ||
| Line 44: | Line 25: | ||
== Si usted quiere realizar depuración paso a paso o ajustada (XDebug) == | == Si usted quiere realizar depuración paso a paso o ajustada (XDebug) == | ||
* Para agregar información de tuning en la barra de estado del navegador, agregar la variable de entorno | * Para agregar información de tuning en la barra de estado del navegador, desde dolibarr 3.8, agregar la variable de entorno MAIN_SHOW_TUNING_INFO con valor 1, para ello incluya la siguiente línea en su fichero apache.conf: | ||
< | <syntaxHighlight lang="ini"> | ||
SetEnv | SetEnv MAIN_SHOW_TUNING_INFO 1 | ||
</ | </syntaxHighlight> | ||
A continuación, compruebe que su navegador no tiene una opción para bloquear la barra de tareas por javasscript. | A continuación, compruebe que su navegador no tiene una opción para bloquear la barra de tareas por javasscript. | ||
| Line 57: | Line 38: | ||
* Modifique el archivo php.ini file añadiendo lo siguientes parámetros: | * Modifique el archivo php.ini file añadiendo lo siguientes parámetros: | ||
< | <syntaxHighlight lang="ini"> | ||
[xdebug] | [xdebug] | ||
xdebug.remote_enable=on | xdebug.remote_enable=on | ||
| Line 68: | Line 49: | ||
xdebug.profiler_enable=0 | xdebug.profiler_enable=0 | ||
xdebug.profiler_enable_trigger=1 | xdebug.profiler_enable_trigger=1 | ||
</ | </syntaxHighlight> | ||
=== [[File:Logo_ubuntu.png|24px]] Ubuntu / Linux === | === [[File:Logo_ubuntu.png|24px]] Ubuntu / Linux === | ||
* Instale el paquete '''php-xdebug''': | * Instale el paquete '''php-xdebug''': | ||
< | <syntaxHighlight lang="bash"> | ||
sudo apt-get install php5-xdebug | sudo apt-get install php5-xdebug | ||
</ | </syntaxHighlight> | ||
* Modique el archivo xdebug.ini añadiendo los siguientes parámetros después de la línea zend_extension=xxx (o similar): | * Modique el archivo xdebug.ini añadiendo los siguientes parámetros después de la línea zend_extension=xxx (o similar): | ||
< | <syntaxHighlight lang="ini"> | ||
; With xdebug 2.1 and more | ; With xdebug 2.1 and more | ||
xdebug.remote_enable=on | xdebug.remote_enable=on | ||
| Line 84: | Line 65: | ||
xdebug.remote_port=9000 | xdebug.remote_port=9000 | ||
xdebug.show_local_vars=off | xdebug.show_local_vars=off | ||
xdebug.profiler_output_dir= | xdebug.profiler_output_dir=/tmp | ||
xdebug.profiler_enable=0 | xdebug.profiler_enable=0 | ||
xdebug.profiler_enable_trigger=1 | xdebug.profiler_enable_trigger=1 | ||
; Add also this with xdebug 2.2 and more | ; Add also this with xdebug 2.2 and more | ||
xdebug.show_mem_delta=1 | xdebug.show_mem_delta=1 | ||
xdebug.trace_output_dir= | xdebug.trace_output_dir=/tmp | ||
xdebug.auto_trace=0 | xdebug.auto_trace=0 | ||
xdebug.trace_enable_trigger=1 | xdebug.trace_enable_trigger=1 | ||
</ | </syntaxHighlight> | ||
=== [[File:Eclipsephp.jpg|24px]] Configuración de Eclipse === | === [[File:Eclipsephp.jpg|24px]] Configuración de Eclipse === | ||
| Line 123: | Line 104: | ||
==== Instalar PHPUnit ==== | ==== Instalar PHPUnit ==== | ||
* Descargar el archivo de la versión desde http://pear.phpunit.de/get/ y descomprimir el contenido en un directorio que se encuentre incluido en el parámetro include_path de su archivo de configuración php.ini. | * Descargar el archivo de la versión desde http://pear.phpunit.de/get/ y descomprimir el contenido en un directorio que se encuentre incluido en el parámetro include_path de su archivo de configuración php.ini. | ||
* También se requiere el módulo xdebug si desea realizar informes de la cobertura de los tests. | * También se requiere el módulo xdebug si desea realizar informes de la cobertura de los tests. | ||
Latest revision as of 08:48, 17 January 2023
Si desea realizar scripts en Perl
- Instalación del plugin Eclipse para Perl: EPIC
Para ello, utilizar el método Find And Install y agregar la URL de actualización: http://e-p-i-c.sourceforge.net/updates
Si trabaja bajo Windows
- WampServer 2 (para disponer de la base de datos Mysql, Apache y PHP todo en uno). El servidor WAMP ofrece el trio MySql+Apache+PHP instalado llave en mano, con posibilidad de cambiar de versión, para cualquiera de estos componentes con un solo clic). ¡Imprescindible!
- Notepad++ (para aquellos que no soportan el uso de Java o un viejo cuco demasiado bajo para Eclipse).
- WinMerge (para la comparación de ficheros o carpetas)
- CygWin (para los comandos patch y los comandos en línea git si prefiere la línea de comandos)
Si usted quiere realizar depuración paso a paso o ajustada (XDebug)
- Para agregar información de tuning en la barra de estado del navegador, desde dolibarr 3.8, agregar la variable de entorno MAIN_SHOW_TUNING_INFO con valor 1, para ello incluya la siguiente línea en su fichero apache.conf:
SetEnv MAIN_SHOW_TUNING_INFO 1
A continuación, compruebe que su navegador no tiene una opción para bloquear la barra de tareas por javasscript.
- Para la depuración línea a línea, instale XDebug:
Windows
- Descargue el archivo dll php_debug_xxx.dll desde http://www.xdebug.org y guárdelo en el directorio /ext de php. Seguidamente active el plugin.
- Modifique el archivo php.ini file añadiendo lo siguientes parámetros:
[xdebug]
xdebug.remote_enable=on
xdebug.remote_handle=dbgp
xdebug.remote_host=localhost
xdebug.remote_port=9000
xdebug.show_local_vars=off
xdebug.profiler_output_dir=c:/temp
xdebug.profiler_append=0
xdebug.profiler_enable=0
xdebug.profiler_enable_trigger=1
Ubuntu / Linux
- Instale el paquete php-xdebug:
sudo apt-get install php5-xdebug
- Modique el archivo xdebug.ini añadiendo los siguientes parámetros después de la línea zend_extension=xxx (o similar):
; With xdebug 2.1 and more
xdebug.remote_enable=on
xdebug.remote_handle=dbgp
xdebug.remote_host=localhost
xdebug.remote_port=9000
xdebug.show_local_vars=off
xdebug.profiler_output_dir=/tmp
xdebug.profiler_enable=0
xdebug.profiler_enable_trigger=1
; Add also this with xdebug 2.2 and more
xdebug.show_mem_delta=1
xdebug.trace_output_dir=/tmp
xdebug.auto_trace=0
xdebug.trace_enable_trigger=1
Configuración de Eclipse
- Abra Eclipse. En el menú Window->Preferences->General->Web Browser, seleccione external web browser, y seleccione Default system web browser.
- Vaya a la sección debug, Window->Preferences->PHP->Debug, y establezca la opción PHP Debugger a XDebug (por defecto este valor está establecido a Zend Debugger). Note que el chekbox “Break at first line” está activado – puede cambiarlo después, si lo necesita.
- Después de haber aplicado los cambios, vaya a la prespectiva PHP Debug, y entre al menú Debug Configurations… Allí, asegúrese que el Server Debugger está configurado como XDebug, y que el PHP server apunta a http://localhost/ o a una dirección correcta. la sección file apunta al archivo index.php, relativo a su workspace, la ruta relativa puede ser /dolibarr/htdocs/index.php.
- Compruebe que la sección URL apunte a la dirección correcta – de lo contrario, desmarque el checkbox “Auto-Generate”, y teclee la dirección correcta. Aplique los cambios y cierre la ventana.
- Debería estar preparado para debugear Dolibarr. Haga clic en Run->Debug o F11 para activar el debugging, Eclipse debe pasar a la vista de Debug, y Dolibarr debe iniciarse en su explorador. Si el chexbox “Break at First Line” está activado, Dolibarr parará en la primera línea. Puede ir paso a paso por las líneas usando los controles de depuración del menú superior izquierdo. Puede poner breakpoints en varios lugares del código y la ejecución del mismo parará en ellos.
- A continuación, para analizar los archivos de perfiles generados por Xdebug, puede instalar KCacheGrind (Linux) o WinCacheGrind (Windows).
Para desarrollar o usar los tests tests PHPUnit
Desde Eclipse
El mejor método es las PHP Tools integration para Eclipse:
http://www.phpsrc.org/eclipse/pti/
De este modo, la instalación y ejecución de los tests PHPUnit se integran directamente en su Eclipse. Modifique la configuración en Eclipse (Windows-Preferences-PHPTools-PHPUnit) tal y como sigue en la pantalla siguiente (haga clic para agrandar):
De lo contrario, deberá realizar instalación manual y ejecución en línea de comandos.
Desde línea de comandos
Instalar PHPUnit
- Descargar el archivo de la versión desde http://pear.phpunit.de/get/ y descomprimir el contenido en un directorio que se encuentre incluido en el parámetro include_path de su archivo de configuración php.ini.
- También se requiere el módulo xdebug si desea realizar informes de la cobertura de los tests.
Ejecutar los tests PHPUnit
- Ir al directorio /test de la versión GIT. Consulte el archivo README para conocer el proceso de ejecución de una batería de tests.
Para desarrollar o usar los test Selenium
Desde Firefox
Instalar el plugin para Firefox Selenium IDE
- Descargar el archivo del plugin Selenium IDE para Firefox.
- Añadirlo en Herramientas - Módulos complementarios de Firefox.
Ejecutar los tests Selenium
- Ir al menú Herramientas - Selinum IDE de firefox.
- Abrir el archivo de tests xml
- Ejecutar el test.
Para generar la documentación Doxygen
- Instalar Doxygen, disponible en http://www.doxygen.org (o en el paquete doxygen bajo Ubuntu).
- Instalar el plugin Eclipse añadiento la url fuente http://download.gna.org/eclox/update/ en la herramienta de actualización de Eclipse.